3. 基本操作

3.1 画面構成

コンソール画面

図3.1 Rのコンソール画面

Rを起動すると、図3.1のコンソール画面が表示されます。コンソール画面の“>”(プロンプト)の後ろに式を入力することで、関数を利用した分析やグラフを描くことができます。

エディタ

Rのコンソール画面に入力したプログラムはRを終了するごとに消えてしまいます。そこで、Rではエディタにプログラムを入力する方が便利です。

図3-2 エディタ画面の開き方

Rのメニューから[ファイル]-[新しいスクリプト]を選択すると、エディタが開きますので、ここにプログラムを入力します。エディタ上のプログラムは、メニューの[編集]-[すべて実行]、あるいは[編集]-[カーソル行または選択中のRコードを実行]で実行することができます。実行するプログラムの行を選択して[Ctrl + R]キーを押すことでも実行されます。複数行のプログラムを同時に実行する場合は、その範囲を選択してください。

図3-3 エディタ画面での実行

図3-4 エディタ画面の保存と開き方

作成したプログラムを保存するには、メニューから[ファイル]-[別名で保存]で保存先のフォルダを選び、ファイル名を付けてください。拡張子は[.R]になります。また、保存したスクリプトはメニューの[ファイル]-[スクリプトを選ぶ]から選択することで開くことができます。

3.2 四則演算とコメントアウト

Rでは、関数を使って計算することができます。例えば、1+1と入力してEnterキーを押すとその答え2が出力されます。四則演算をやってみましょう。

In [ ]:
1+4 #足し算 # はコメントアウト
5-3 #引き算
2*3 #掛け算
8/4 #割り算
3^2 #累乗

#は「コメントアウト」を表します。#の後に書かれた文章・コマンドは実行されません。コメントアウトを利用することで、プログラムの一部を削除せずに省略したり見直すときに分かりやすいように説明やメモを残したりすることができます。

3.3 関数と引数

Rでは決められた関数を使って計算式を書くことができます。関数には以下のようなものがあります。

In [8]:
sqrt(16) #平方根
abs(-10) #絶対値
round(10.5) #四捨五入
round(7.2)
log(2) #自然対数
log(2, base=10) #常用対数、対数の底が10
sin(30)#サイン
cos(30)#コサイン
tan(30) #タンジェント
4
10
10
7
0.693147180559945
0.301029995663981
-0.988031624092862
-0.9880316
0.154251449887584
-6.40533119664628

3.4 変数

Rでは数字をそのまま使わず、変数に代入して使います。変数に値や式を代入するには、“変数 = 値”、“変数 = 式”と入力します。保存した変数は変数名を入力すると表示されます 。

In [ ]:
data = 2 #dataに値"2"を代入する
data #dataの確認
data = 1+2 #dataに式"1+2"を代入する
data #dataの確認、dataは上書きされる

3.5 作業ディレクトリ

ファイルからデータやプログラムを読み込んだり、ファイルにデータを書き出したりする場所を作業ディレクトリといいます。起動時はRの実行ファイルがある場所が作業ディレクトリとなっており、関数getwd()で確認できます。

In [ ]:
getwd() #現在の作業ディレクトリを確認する

また、関数setwd()実行することで、作業ディレクトリを変更することができます。

In [ ]:
setwd("特定のディレクトリ") #作業ディレクトリを変更する、環境によって異なります。支援組織Webページ上では変更できません。

Windowsの場合

メニューの[ファイル]から[ディレクトリの変更...]を選択し、作業ディレクトリを選択することで変更できます。

図3.5 作業ディレクトリの変更

Mac OS Xの場合

メニューの[その他]から[作業ディレクトリの変更...]を選択すると、作業ディレクトリを選択することで変更できます。

3.6 パッケージの利用

パッケージのインストール方法は要検討

Rはインストールした初期の状態でも統計手法を利用することができます。標準では実装されていない様々な統計手法を使うためには、「パッケージ」をインストールして用いることになります。2016年10月現在、CRANだけでも9400件以上のパッケージが公開されています。ここでは心理学研究のために広く利用されているパッケージpsychを例に、インストール方法を紹介します。

Windowsの場合

図3.6 パッケージのインストール

コンソール画面をアクティブにした状態で、メニューの[パッケージ]-[パッケージのインストール]を選択します。すると、[Cran mirror]というダイアログボックスが開きます。

図3.7 Cran mirrorの選択

[Cran mirror]というダイアログボックスでは、パッケージをダウンロードするためのミラーサイトを指定します。2017年7月現在、Japan[Tokyo]を選ぶことができます。

図3.8 Cran mirrorの選択

次に、[Packeges]ダイアログボックスが表示されます。表示されたパッケージリストから、ここでは[psych]パッケージを選択して[OK]をクリックします。

インストールしたパッケージを利用するためには、Console画面でコマンドを実行する必要があります。これで、[psych]パッケージを利用することが可能になります。

注意事項

jupyter上で起動するためには、"R:\WinPython\WinPython-64bit-3.6.1.0Qt5\WinPython >Command Prompt.exe"を立ち上げて以下のコマンドを入力する必要があります。

R install.package("psych")

In [ ]:
library(psych)

3.7 その他の機能

Rでは空白は無視される

計算実行の際に、空白は無視されます。

式の入力を途中で止めるときは,Escを押す

式を書いた途中で誤って計算を実行してしまった場合、通常の“>”(プロンプト)の代わりに,式が継続していることを示す“+”が表示されます。[Esc]キーを押しと式の入力が中断できます。

ヘルプ機能

“?”を関数の前に置くと、各関数のオプションを開くことが出来ます。

In [ ]:
?hist #ヘルプ